Troubleshoot failure to upload to cloud lab or device

When uploading a file to the cloud lab repository or mobile lab device, you receive the following error:

Cause

This usually happens during manual testing.

What you are seeing is a network security block on the local user computer. When the user tries to upload a file to a device, it requires searching of the local computer system. There is a security block that is preventing this from happening, per a security policy of your company network. It all depends on the security policies in those networks, and/or on your computer.

Perfecto does not cause this issue as we have no control over your local computer file system.

Solution 1

The end result is to have your Infra and Security team review the issue. They need to see what happens, which is the cloud is asking to open a pop up to select a file on the local computer. This is standard for any upload request to anything from a web browser. As an example: you would see the same pop up, if you tried to save an excel document to your computer.

It is a file system restriction that only your Infra and/or Security team can resolve.

Solution 2

The other suggestion is to upload the IPA or APK file to the cloud repository using REST API commands. From there, a user can install the app from the cloud repository, thereby eliminating the issue with the local users computer security completely.

Related Articles

See also the Perfecto Knowledgebase.