Failure to upload to cloud lab or device

When uploading a file to the cloud lab repository or mobile lab device, you may receive the following error: Failed to upload <file-name>

Cause

This error usually occurs during manual testing. It is related to a network security block on the local user computer. When you try to upload a file to a device, it requires searching of the local computer system. If this error occurs, it indicates that a security block prevents this from happening, per a security policy of your company network. It all depends on the security policies in those networks, and/or on your computer.

Perfecto does not cause this issue, nor does Perfecto have any control over your local computer's file system.

Solution 1

Have your Infra and Security team review the issue. They need to see what happens, which is that the cloud is asking to open a pop-up window to select a file on the local computer. This is standard for any upload request to anything from a web browser. As an example: you would see the same pop up, if you tried to save an excel document to your computer.

It is a file system restriction that only your Infra and/or Security team can resolve.

Solution 2

Upload the IPA or APK file to the cloud repository using REST API commands. From there, a user can install the app from the cloud repository, thereby eliminating the issue with the local computer's security.